LNK603 operation at lower temperatures

9 posts / 0 new
Last post
vkv
LNK603 operation at lower temperatures

We have a power supply (+3.3V+/-4%, 0.6A) based on LNK603 - schematic is attached. I works pretty well at temperatures appr. from -10 to 85degC. Now we faced with necessity to extend the operation temperatures to full industrial range (-40...85degC).

I tried to increase the values of the resistors in the feedback net (in order to shift the level of CV to CC mode switching a bit higher) and the values of the input and output capacitors (just thought that the caps could loose their capacity).

All this did not help much. At temperatures below -12...-15degC the power supply will not start with full load - its output voltage is reduced and ripples increased dramatically. Using a scope one can see two different frequency components in the output voltage ripples - LNK603 switching frequency and an additional frequency of 2...3kHz.

Is there a chance to modify the design to get it working? What modifications are necessary for this?

Thanks.

PI-Surak
LNK603 operation at lower temperatures

Check BP voltage and see if it is stable 6V. You may need a better quality bypass cap across BP pin. You may also need to have more bias current fed into BP pin by lowering resistor feed into BP pin. Check capacitor quality first though...

vkv
Thank you for your fast

Thank you for your fast response.

I checked the voltage at 'BP'. It is 6.51-6.52Vdc both on the table and in the freezer at -20degC. With lowered from 6.2 to 3.3kohm resistor the voltage at 'BP' did not change and the power supply will not start at cold still...

The capacitor across 'BP' and 'S' is 1uF +/-10% 25V X7R rated -55...125 degC manufactured by Yageo.

Any other idea I could try?

PI-Surak
Thank you for your fast

Check to see there is any drain switching at all -- previous to start up there should be a few pulses that sample condition. This would be seen as three or four pulses spaced over many miliseconds. This will give me some clue as to what is stalling

vkv
Results

Hi,
Just re-tested the PS on the table and in the fridge once again. The results are attached in four pictures. The two first demonstrate output voltage and it ripples at -22degC and at 25degC. The input voltage is 230V. Full load (1.9W) is applied in both cases.
Two other pictures show the drain voltage in the same conditions.

PI-Surak
Results

I don't see anything here that looks abnormal. Try better quality caps for bias capacitor and output capacitors as they are electrolytic and may not be funtioning well at such low tem and see if problem goes away. If it doesn't then I am afraid controller has lost accuracy in its threshold detection for regulation

vkv
I don't see anything here that looks abnormal.

The output caps are electrolytic but rated for -40degC.
Actually I tried already to increase them to have higher ripple current, connect two (and even three) in parallel, replace them by tantalum... Neither option helped much.
As for bias capacitor - it is already X7R. COG would be better probably but 1uF COG seems to be a certain difficulty.

Anyway if the problem is in the chip then which one would you recommend to use to achieve the normal operation in the industrial temperature range -40...85degC?

Thanks.

vkv
Some more info

Today I tried to heat up the chip when in freezer with the help of SMT resistor (100mW of dissipated power) glued on top of LNK.
It helped! After 5-8 minutes of such "heating" the output voltage and its ripple arrived to the designed values.
To my point of view this directly approves that the problem is completely related to the chip ans has nothing to do with other components around it.

PI-Surak
Some more info

I don't see anything else I can advise since -40C is out spec range